Roma isn't including added attributes in documentation

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Roma isn't including added attributes in documentation

Dot Porter-2
Hi everyone,

I haven't used Roma in a long time so I don't remember if this has been an issue before. I've created some new elements + attributes, and when I generate the documentation, the attributes aren't included (the elements are). Is this a known issue, is there something I'm doing wrong? The attributes do show up in the ODD file out of Roma.

Thanks,
Dot

P.S. Hope y'all who are there are having fun in Lyon!

--
*~*~*~*~*~*~*~*~*~*~*
Dot Porter (MA, MSLS)       
Digital Medievalist, Digital Librarian
Email: [hidden email]
Personal blog: dotporterdigital.org
Medieval Electronic Scholarly Alliance: http://www.mesa-medieval.org
MESA blog: http://mesamedieval.wordpress.com/
MESA on Facebook: https://www.facebook.com/MedievalElectronicScholarlyAlliance
*~*~*~*~*~*~*~*~*~*~*
Reply | Threaded
Open this post in threaded view
|

Re: Roma isn't including added attributes in documentation

Martin Holmes
Hi Dot,

Could you send me the ODD file as a zipped attachment to my email
address? I'll see if I can reproduce the problem, or see anything weird
about the ODD file.

Cheers,
Martin

On 2015-10-28 08:48 PM, Dot Porter wrote:

> Hi everyone,
>
> I haven't used Roma in a long time so I don't remember if this has been
> an issue before. I've created some new elements + attributes, and when I
> generate the documentation, the attributes aren't included (the elements
> are). Is this a known issue, is there something I'm doing wrong? The
> attributes do show up in the ODD file out of Roma.
>
> Thanks,
> Dot
>
> P.S. Hope y'all who are there are having fun in Lyon!
>
> --
> *~*~*~*~*~*~*~*~*~*~*
> Dot Porter (MA, MSLS)
> Digital Medievalist, Digital Librarian
> Email: [hidden email] <mailto:[hidden email]>
> Personal blog: dotporterdigital.org <http://dotporterdigital.org>
> Medieval Electronic Scholarly Alliance: http://www.mesa-medieval.org
> MESA blog: http://mesamedieval.wordpress.com/
> MESA on Facebook:
> https://www.facebook.com/MedievalElectronicScholarlyAlliance
> *~*~*~*~*~*~*~*~*~*~*
Reply | Threaded
Open this post in threaded view
|

Re: Roma isn't including added attributes in documentation

Dot Porter-2
Yes, I'll do that offlist. Thanks Martin!

Dot

On Wed, Oct 28, 2015 at 4:09 PM, Martin Holmes <[hidden email]> wrote:
Hi Dot,

Could you send me the ODD file as a zipped attachment to my email address? I'll see if I can reproduce the problem, or see anything weird about the ODD file.

Cheers,
Martin

On 2015-10-28 08:48 PM, Dot Porter wrote:
Hi everyone,

I haven't used Roma in a long time so I don't remember if this has been
an issue before. I've created some new elements + attributes, and when I
generate the documentation, the attributes aren't included (the elements
are). Is this a known issue, is there something I'm doing wrong? The
attributes do show up in the ODD file out of Roma.

Thanks,
Dot

P.S. Hope y'all who are there are having fun in Lyon!

--
*~*~*~*~*~*~*~*~*~*~*
Dot Porter (MA, MSLS)
Digital Medievalist, Digital Librarian
Email: [hidden email] <mailto:[hidden email]>
Personal blog: dotporterdigital.org <http://dotporterdigital.org>
Medieval Electronic Scholarly Alliance: http://www.mesa-medieval.org
MESA blog: http://mesamedieval.wordpress.com/
MESA on Facebook:
https://www.facebook.com/MedievalElectronicScholarlyAlliance
*~*~*~*~*~*~*~*~*~*~*



--
*~*~*~*~*~*~*~*~*~*~*
Dot Porter (MA, MSLS)       
Digital Medievalist, Digital Librarian
Email: [hidden email]
Personal blog: dotporterdigital.org
Medieval Electronic Scholarly Alliance: http://www.mesa-medieval.org
MESA blog: http://mesamedieval.wordpress.com/
MESA on Facebook: https://www.facebook.com/MedievalElectronicScholarlyAlliance
*~*~*~*~*~*~*~*~*~*~*
Reply | Threaded
Open this post in threaded view
|

Re: Roma isn't including added attributes in documentation

Peter Stokes-2
Dear all,

Apologies for dragging up an old thread, especially if I’ve missed the answer, but I think I’ve come across a different manifestation of the same Roma problem that Dot had in October 2015 (see below), and I can't find any response or GitHub ticket so I’m not sure if anything happened since.

My problem is that if I add a new element and then add attributes to that element on Roma then the resulting schema is missing the attributes. It turns out they are in the ODD, but with attDef's @mode="change" instead of "add". Correcting the ODD by hand and then generating the schema via Oxygen or OxGarage works. So the workaround is easy enough but I assume the issue should still be recorded in a Roma ticket in the hope of fixing it one day. I’m happy to add one if that will help but I wanted to check I’m not missing anything first.

Thanks, and all the best,

Peter



> On 29 Oct. 2015 at 13:46, Dot Porter <[hidden email]> wrote:
>
> Yes, I'll do that offlist. Thanks Martin!
>
> Dot
>
> On Wed, Oct 28, 2015 at 4:09 PM, Martin Holmes <[hidden email]> wrote:
> Hi Dot,
>
> Could you send me the ODD file as a zipped attachment to my email address? I'll see if I can reproduce the problem, or see anything weird about the ODD file.
>
> Cheers,
> Martin
>
> On 2015-10-28 08:48 PM, Dot Porter wrote:
> Hi everyone,
>
> I haven't used Roma in a long time so I don't remember if this has been
> an issue before. I've created some new elements + attributes, and when I
> generate the documentation, the attributes aren't included (the elements
> are). Is this a known issue, is there something I'm doing wrong? The
> attributes do show up in the ODD file out of Roma.
>
> Thanks,
> Dot
>
> P.S. Hope y'all who are there are having fun in Lyon!
>
> --
> *~*~*~*~*~*~*~*~*~*~*
> Dot Porter (MA, MSLS)
> Digital Medievalist, Digital Librarian
> Email: [hidden email] <mailto:[hidden email]>
> Personal blog: dotporterdigital.org <http://dotporterdigital.org>
> Medieval Electronic Scholarly Alliance: http://www.mesa-medieval.org
> MESA blog: http://mesamedieval.wordpress.com/
> MESA on Facebook:
> https://www.facebook.com/MedievalElectronicScholarlyAlliance
> *~*~*~*~*~*~*~*~*~*~*
>
>
>
> --
> *~*~*~*~*~*~*~*~*~*~*
> Dot Porter (MA, MSLS)      
> Digital Medievalist, Digital Librarian
> Email: [hidden email]
> Personal blog: dotporterdigital.org
> Medieval Electronic Scholarly Alliance: http://www.mesa-medieval.org
> MESA blog: http://mesamedieval.wordpress.com/
> MESA on Facebook: https://www.facebook.com/MedievalElectronicScholarlyAlliance
> *~*~*~*~*~*~*~*~*~*~*